Archive for the ‘Security’ Category

Upgrade Your Wordpress to 2.8.4!

In case you are still using an outdated Wordpress between version 2.8 to 2.8.3, please update it to the latest version.
There is a vulnerability on these versions where a person without the admin e-mail address may reset the admin password.

Where’s Xunlei?
Xunlei Post still exists. It's here.